Author Topic: Panasonic - Country/City/State tag correction  (Read 1437 times)

nicofo

  • Newbie
  • *
  • Posts: 3
Panasonic - Country/City/State tag correction
« on: August 13, 2014, 05:18:45 PM »
Hi,
on your page, I see there are some tags foreseen for location naming (for country, state, city, ...): http://www.sno.phy.queensu.ca/~phil/exiftool/TagNames/Panasonic.html
  • 0x0069    Country
  • 0x006b    State
  • 0x006d    City
  • 0x006f    Landmark
Actually, "City" is not correct and there is one missing. Here is the complete list, sorted by geographical hierarchy (I have a TZ40):
  • 0x0069    Country   (accurate name on the camera: "Country/Region" - French "Pays")
  • 0x006b    State   (accurate name on the camera: "State/Prov./County" - French "Région")
  • 0x006d    County   (accurate name on the camera: "County/Township" - French "Département")
  • 0x0080    City   (accurate name on the camera: "City/Town/Village" - French "Ville")
  • 0x006f    Landmark (French "Repère")
(note that the French name is not as long as the English one)

Regards,

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 14554
    • ExifTool Home Page
Re: Panasonic - Country/City/State tag correction
« Reply #1 on: August 15, 2014, 08:37:05 PM »
It seems that Panasonic has changed tag 0x006d for the TZ40.  I will have to look into this.

Thanks for this report.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).