Author Topic: IPTC Keywords string truncated at 64char unless -m used  (Read 1508 times)

3design

  • Jr. Member
  • **
  • Posts: 29
IPTC Keywords string truncated at 64char unless -m used
« on: November 15, 2012, 05:58:57 PM »
I just noticed an odd behavior when writing from a csv list of test tags to a list of test files.

The command I'm writing with is simple: exiftool -csv=tagsdb.csv -ext tif -r .
Inside that file, the IPTC:Keywords column contains: TEMPLATE, keywords1, keywords2, keywords3, keywords4, keywords5, keywords6

The keywords actually written with the above command are: TEMPLATE, keywords1, keywords2, keywords3, keywords4, keywords5,

If I add -m to the write command, the full string is written. I understand there's a 64-char limit to the keywords, but as I understand it, that's 64 chars "per comma-delimited string" and not 64 chars in total, so am I doing something wrong in my write command, or maybe missing something other than the -m? Is -m the proper solution to this? I have a feeling it's because the keywords are coming from a single cell in the CSV and are being counted as one string, even though they are comma-delim in that cell.

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 14937
    • ExifTool Home Page
Re: IPTC Keywords string truncated at 64char unless -m used
« Reply #1 on: November 15, 2012, 06:25:57 PM »
From the -csv option documentation:

    Note that ist-type tags are stored as simple strings in a CSV file, but the -sep
    option may be used to split them back into separate items when importing.


You should add -sep ", " to your command to fix your problem.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).