Author Topic: Warning messages  (Read 1532 times)

-Sulli-

  • Jr. Member
  • **
  • Posts: 10
Warning messages
« on: September 15, 2016, 04:11:37 PM »
Hi all

I'm getting a couple of warning messages when trying to update the "Sony Date Time".  All four photos were taken within about 10 minutes of each other but for some reason it's having issue with two JPGs and in different ways from what I can tell.

Code: [Select]
exiftool -ext JPG "-alldates-=0:00:0 09:02:28" "-filemodifydate-=0:00:0 09:02:28" "-sonydatetime-=0:00:0 09:02:28" \SonyRX100\2016-08-01
Warning: Month '13' out of range 0..11 when shifting SonyDateTime - /SonyRX100/2016-08-01/DSC02230.JPG
Warning: Invalid time string (43299:05:01 149:75:62) when shifting SonyDateTime - /SonyRX100/2016-08-01/DSC02231.JPG
    1 directories scanned
    4 image files updated

Having looked at the EXIF data the dates all appear to update okay, so I'm not sure if I can just ignore these warnings or if it's breaking something else that I've not spotted and I need to do something different?

Cheers

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 14759
    • ExifTool Home Page
Re: Warning messages
« Reply #1 on: September 15, 2016, 04:16:53 PM »
Your command works without warnings for me with a few sample RX100 images.  Could you email me a problem file so I can reproduce these warnings? (phil at owl.phy.queensu.ca)

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

-Sulli-

  • Jr. Member
  • **
  • Posts: 10
Re: Warning messages
« Reply #2 on: September 15, 2016, 04:30:35 PM »
Hi Phil

I've just sent you the two files that are causing these warning messages.

I've run the same commands on a folder containing 119 JPGs with no warning messages.  So it seems to have issues with those particular JPGs.

Thanks
Richard

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 14759
    • ExifTool Home Page
Re: Warning messages
« Reply #3 on: September 15, 2016, 09:53:19 PM »
I got the files.  I'll take a look at them first thing tomorrow.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

Phil Harvey

  • ExifTool Author
  • Administrator
  • ExifTool Freak
  • *****
  • Posts: 14759
    • ExifTool Home Page
Re: Warning messages
« Reply #4 on: September 16, 2016, 07:57:21 AM »
I think this may have to do with the fact that these pictures seem to be captures while taking video.  Maybe the metadata is structured differently in this mode.  I'll try it with my own RX100 to see if I can figure this out.

The bottom line is that ExifTool seems to be not decoding parts of the maker notes properly for these images.  There are two SonyDateTime values in normal RX100 JPEG images.  Only one of them is getting shifted in these files.  The other (if it exists) is not being decoded properly.

- Phil
...where DIR is the name of a directory/folder containing the images.  On Mac/Linux, use single quotes (') instead of double quotes (") around arguments containing a dollar sign ($).

-Sulli-

  • Jr. Member
  • **
  • Posts: 10
Re: Warning messages
« Reply #5 on: September 16, 2016, 10:11:42 AM »
That makes sense.  I did notice that the two photos having the issues were the ones captured during video recording so thought it might be something to do with that.

Thanks for looking into it.

Cheers
« Last Edit: September 16, 2016, 01:55:38 PM by -Sulli- »