Author Topic: Misleading exiftool not found dialog  (Read 785 times)

Kenneth Evans

  • Jr. Member
  • **
  • Posts: 12
Misleading exiftool not found dialog
« on: July 21, 2018, 12:11:34 PM »
I had been using ExifToolGui for a while when it started popping up an error dialog saying "exiftool not found" and came up with nothing in the UI (at least the filelist part) and with all menus disabled (except maybe exit).  I do have exiftool.exe in the same directory as ExifToolGui.exe, and it was working.

This is on Windows 10 64-bit.

I copied the whole Exiftool file structure to another computer, and it worked fine there.

After quite a bit of debugging, I discovered it was actually functional.  After I navigated to a vaild directory, it worked as expected, and stopped giving the exiftool not found dialog.

So, apparently this dialog is being shown when the real problem is that it was left with an invalid directory (I had renamed it).  It can be fixed by navigating to a valid one.

Since this program is no longer being maintained, this is just a heads up in case someone else has the same problem.

dplaut

  • Newbie
  • *
  • Posts: 1
Re: Misleading exiftool not found dialog
« Reply #1 on: July 22, 2018, 03:32:36 PM »
What is a "valid directory?"