Author Topic: -stay_open stdIn Windows filename problem  (Read 140 times)

Thyphoon

  • Newbie
  • *
  • Posts: 3
-stay_open stdIn Windows filename problem
« on: January 30, 2019, 08:43:45 AM »
Hello,
Tanks for this great tool  ;D
I use Exiftool 10.31 (i have tested 11.26 too) with Windows 10 64bit
I Work on a Picasa(R.I.P) replacement application who use ExifTool to read and Write Metadatas.
I have an engine who use "-stay_open -@ -" Exiftool function in a Thread and i send command to StdIn. It's great, fast, powerfull 8).
But with some path, Exiftool return "File Not Found"... :-[
After a very long time to understand the problem, i found it's all path with special Character (éàèetc...).
I found on this forum lot of information about window and problem with filename on console. But not with  -stay_open and write command on StdIn
I try to force  to write string in UTF8 / Unicode / Ascii on ExfiTool's StdIN but no succes :'( .
I see on this forum and the documentation to try "-charset FILENAME=UTF8" but i have "Warning: Tag 'charset' is not supported" i don't understand why  ! :'(
"-charset FILENAME=UTF8" always exist ?

else do you plan to support :
-  http encode format filename ???
- or maybe a base 64 filename like -base64Filename RDpcSW1hZ2VzXDIwMTgtMDgtMjMgTGEgVmFsw6llIGRlcyBTaW5nZXNcSU1HUDcwMDYuSlBH  8)
to strike the problem ?
Thanks for you help.
Regards,

And excuse me for my bad english  ::)
« Last Edit: January 30, 2019, 10:05:42 AM by Thyphoon »

StarGeek

  • Global Moderator
  • ExifTool Freak
  • *****
  • Posts: 2365
Re: -stay_open stdIn Windows filename problem
« Reply #1 on: January 30, 2019, 12:50:27 PM »
How are you using -charset FILENAME=UTF8

The error response you list indicates that somehow exiftool is reading Charset as a tag, not as a command option.  This is usually an indication of an error in how it is entered.

On the command line, make sure it appears as above, no quotes around the whole thing.

In a stay open file, it should appear as:
-charset
FILENAME=UTF8
Troubleshooting hints:
* When posting, include your OS, Exiftool version, and type of file you're processing (MP4, JPG, etc).
* Double all percent signs (%) in a Windows batch file.
* If your GPS coords are negative, make sure and set the GpsLatitudeRef and GpsLongitudeRef tags correctly.

Thyphoon

  • Newbie
  • *
  • Posts: 3
Re: -stay_open stdIn Windows filename problem [Resolved]
« Reply #2 on: January 31, 2019, 01:54:14 AM »
You are my Hero  ;D
Yes my error is to send the command on one line
Code: [Select]
-charset FILENAME=utf8
and not in two line
Code: [Select]
-charset
FILENAME=utf8
That run perfectly !

Big Thanks ! may be add this information in the documentation more visible  :P